
Analyzing PURL Usage at your Library 
 
Getting started: 

1) Gather network information for your institution 
2) Log in to the FDLP PURL Usage Report 
3) Draft ‘patterns’ for your library 
4) Fine tune and save patterns for your library’s profile on the Library Report Dashboard  
5) Run the report 
6) Analyze your report 

 

1) Gather network information for your institution, including: 
 Website address 

 Catalog address 
o If you have a discovery layer, be sure to identify the address of the layer as well as the 

classic catalog 

 LibGuide domain 

 Learning Management System’s domain 

 Wireless networks 

 Ethernet 

 VPN tunnels 
 

Ask your IT staff to identify: 

 Individual IP addresses 

 IP address range(s) 

 IP address blocks, ex. Classless Inter-Domain Routing (CIDR) blocks 
 

You will have the following identifying information for your library: 

 Website address 

 Catalog address 
o If you have a discovery layer, be sure to identify the address of the layer as well 

as the classic catalog 

 LibGuide or subject guide domain 

 Learning Management System’s domain 

 Wireless networks 

 Ethernet 

 VPN tunnels 

 IP address: 
o Individual IP addresses 
o range(s) 
o blocks, ex. Classless Inter-Domain Routing (CIDR) block 

 

2) Log into the FDLP PURL Usage Report tool 
User name = library number (ex. 0123C) 
Password = internal password (ex. FDLP12345) 
Email askGPO if you do not have your log in information 

https://gpo.custhelp.com/app/ask/session/L3RpbWUvMTQ1ODc0ODI5Ny9zaWQvVUNuelliTW0=
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3) Draft ‘patterns’ for your library 
 
Patterns = The search strings you are asking the PURL Usage report to look for and report back to you 
 
Hint – in the PURL Usage tab, run an All PURL referrals by target report and try to isolate some of the 
more obvious networks and domains used by your library. 
 
Tips: 

A  . [period] searches for a period and will only retrieve data when a period is found exactly 
where you specify in your pattern 
 
An * [asterisk] searches for any characters – at least one (that includes a period) 
 
Do not save anything after .edu  .com  .gov   
 
An * substitutes one section of the IP address, including a period  
 
Do not use a wildcard at the beginning of an IP address 
 
Libraries are able to save IP address ranges: 

192.168.0.0 (single address) 
192.168.0.0/24 (CIDR block) 
192.168.0.1-192.168.0.100 (address range) 
192.168.0.0+10 (IP address plus subsequent 10 addresses) 

 
Examples of domain, network, and host patterns 

Pattern Will retrieve Will not retrieve 

*.example.org 
abc.example.org 

abc.myexample.org 
abd.def.example.org 

*example.org 

abc.example.org 

example.org abd.def.example.org 

abc.myexample.org 

*.*example.org 
abd.def.example.org abc.example.org 

abc.myexample.org example.org 

example.org*. 
Invalid - a domain cannot end with a 
period 

  

example.org* 

example.org2 example.org 

example.org.gov abc.example.org 

example.org2.gov   

example.org2.gov.com   

example.org*.* 
example.org2.gov example.org2 

example.org2.gov.com example.org.gov 

example.org example.org 
An exact match so no other domains are 
retrieved 

 
 
 



3 
 

Examples of IP address patterns 

Patterns Explanation 

192.168 Invalid pattern – incomplete IP address 

192.168.0.1*  Invalid pattern - IP addresses do not extend beyond the 4th section of 
numbers 

*.168.0.0  Invalid pattern - cannot have a wildcard at the beginning of an IP 
adddress 

*.* Invalid pattern - cannot have a wildcard at the beginning of an IP 
adddress 

192.168.* Valid pattern - will match 192.168.0.1 and 192.168.1.1 

192.168.0.*  Valid pattern - will match 192.168.0.1 and 192.168.0.2 and so on 

192.*.0.*  Valid pattern - will match 192.168.0.1, 192.167.0.1 and 192.168.0.2 and 
so on 

192.168.0.1 Valid pattern - single IP address 

192.168.0.0/24 Valid pattern - CIDR block 

192.168.0.1 - 
192.168.0.100 

Valid pattern - IP address range 

192.168.0.0 + 10 Valid pattern - group of 10 IP addresses 

134.129.9.*  Valid pattern - will retrieve usage data for anything that matches the first 
3 sections of numbers in the IP Address, such 
as 134.129.9.17, 134.129.9.166, and 134.129.9.235 

 
The goal is to identify your library’s networks and IP addresses and to translate them into patterns. 
 

4) Fine tune and save patterns for your library’s profile on the Library Report 
Dashboard 
 
Save patterns 
Click Edit. 
Click the plus sign and fill out the patterns and the Pattern Note. 
Click Save. 
 
Delete patterns 
Click Edit. 
Click the minus sign next to the pattern to be deleted. 
Click Save. 
 
Run a report ‘on-the-fly’ 
Select a month in the drop down box and click Generate Report. 
Open up the report and review it. Does the results match what you expected? 
Make any necessary adjustments to the patterns. 
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Rerun the report as often as needed. 
 

5) Run your monthly reports 
 

Common issues 
High TTL (Time to Live) setting 
Duplicate entries in the report that looks like a PURL was clicked on several times in the same minute or 
second may be a result of a high TTL setting. To minimize this in future reports, lower your TTL setting to 
give the other server time to respond to the link request. 
 
Link checkers 
Reports with link checker data typically has a wide swath of usage hits that occur at regular intervals 
over a period of time. If that happens, let GPO staff know what the IP address of your link checker is and 
we’ll route your link checker to a different server so it doesn’t muddy your usage data. 
 
Low usage? 

 Test your patterns using different monthly data 

 Are you patterns saved correctly? 

 Are you using PURLs? 
 
If you find you truly do have low usage, use it as leverage to build the digital depository collection. 
 

6) Analyze your FDLP PURL Usage report 
 
Note – this tutorial was created using Microsoft Office Excel 2013. Instructions will vary for other 
versions of Excel.  
 

What are people clicking on? 
 
Configure the SuDoc Number so you only see the SuDoc stem 
Click on the column to the right of the SuDoc Number column to select it and on the Home tab, click 
Insert. 
Select the SuDoc number column. 
Under the Data tab, click Text to Columns. 
In the dialog box, leave the file type at the “Delimited” default and click Next. 
Check the box next to Other, and type in a colon character. 
Click Next. 
Leave everything at default and click Finish. 
Name the new column “Cutter” or something similar. 
This sheet is the “master data tab” from which several reports can be run. 
 
Pivot the data 
Click the blank area next to cell A1 to select the entire table. 
Under the Insert tab, click PivotChart, and then select PivotChart & PivotTable. 
In the dialog box, leave everything at default to put the PivotTable into a New Worksheet, click OK. 
In the PivotTable, drag the SuDoc Number field down to the AXIS area. 
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Drag the same field down to the VALUES area. 
 
Customize the chart 
Change it to a Bar chart in the Design tab. 
Add data labels to the chart by clicking once on the chart and then on the green plus sign to the right of 
the chart. Select Data Labels > Outside End. 
Sort the list by right clicking in a cell of the Count of SuDoc Number column and selecting Sort by… 
 
Name the tab on your spreadsheet and save it. 
 

When did people click on PURLs? 
 
In the master data tab, first convert the Timestamp (in Eastern Time) to your local time zone, if 
needed. 
Select the Timestamp column and on the Home tab, click Insert. 
Click in the first cell of the new column. 
The formula to convert to your local time zone is: =YourTimestampCell+or-TIME(#,0,0) 
 
The plus or minus information and the number can be found below 

 To covert the PURL Usage Report Timestamp to my local… 

I am located in 
this time zone:  

Standard Time 
(fall/winter) 

Daylight Savings Time  
(spring/summer) 

When my local time zone 
does not observe Daylight 

Savings Time 
(spring/summer) 

=TimestampCell + or - (#,0,0) 

Guam/FSM 
(Chamorro) 

+ 15 N/A 14 

Samoa - 6 N/A 7 

Hawaii - 5 N/A 6 

Alaska - 4 4 5 

Pacific - 3 3 4 

Mountain - 2 2 3 

Central - 1 1 2 

Eastern - No conversion No conversion 1 

Atlantic + 1 N/A No conversion 

 
Type in the formula and click Enter. 
Click in the new converted timestamp cell and mouse over the lower right corner until the plus sign 
appears.  
Double click on the plus sign to draw the formula down the column. 
Name the new column something like “Local Timestamp”. 
 
Pivot the data 
Click the blank area next to cell A1 to select the entire table. 
Under the Insert tab, click PivotChart, and then select PivotChart & PivotTable. 
In the dialog box, leave everything at default to put the PivotTable into a New Worksheet, click OK. 
In the PivotTable, drag the Local Timestamp field down to the AXIS area. 
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Drag the same field down to the VALUES area. 
In the Local Timestamp column running down the left side, right click on any of the cells and select 
Group. 
Group by Hours and click OK. 
 
Customize the chart 
Add data labels to the chart by clicking once on the chart and then on the green plus sign to the right of 
the chart. Select Data Labels > Outside End. 
 
Alternate Chart – Count of PURL usage by day of the month 
Right click in a cell in the Timestamp column again and select Group. 
Unselect Hours and select Days. 
Click OK. 
 
Name the tab on your spreadsheet and save it. 
 

What tools were being used when they found your PURLs? 
 
In the master data tab, pivot the data 
Click the blank area next to cell A1 to select the entire table. 
Under the Insert tab, click PivotChart, and then select PivotChart & PivotTable. 
In the dialog box, leave everything at default to put the PivotTable into a New Worksheet, click OK. 
In the PivotTable, drag the Pattern Note field down to the AXIS area. 
Drag the same field down to the VALUES area. 
 
Customize the chart 
Add data labels to the chart by clicking once on the chart and then on the green plus sign to the right of 
the chart. Select Data Labels > Outside End. 
Change it to a Pie chart in the Design tab. 
Some of the data will report what tool was being used. Some of the data will report which network was 
being used because the tool name was not transferred to the PURL server.  
 
Name the tab on your spreadsheet and save it. 
 

What were people clicking on over time? 
 
First compile as many months of data as you want into a new worksheet. You can run up to 12 months 
of older reports in the Library Report Dashboard.  
Make sure the columns all match. 
Make sure the SuDoc Number column has been parsed on the colon character so it only displays the 
SuDoc stem. 
 
Pivot the data 
Click the blank area next to cell A1 to select the entire table. 
Under the Insert tab, click PivotChart, and then select PivotChart & PivotTable. 
In the dialog box, leave everything at default to put the PivotTable into a New Worksheet, click OK. 
In the PivotTable, drag the Local Timestamp field down to the AXIS area. 
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Right click on any Timestamp cell and select Group. 
Group the data by Month and click OK. 
In the AXIS box, drag the same Timestamp field over to the LEGEND or COLUMNS area. The grouping 
should remain and the months should display across the top. 
Drag the SuDoc Number field down to the AXIS or ROWS area. 
Drag the same field down to the VALUES area. 
 
Move the data to a clean worksheet 
Copy the data and values. 
On the Home tab, under Paste, select Paste as Values. 

 
 
Customize the table 
Delete blank rows and columns. 
Select columns and on the Home Tab, under Conditional Formatting, select a Color Scale. 
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Select the column again and on the Home Tab, under Conditional Formatting, select Manage Rules. 
Double click on the rule for the selected data. 

 
 
Change the color scale to blue and click OK. 

 
 
Name the tab on your spreadsheet and save it. 

 
Questions? askGPO - www.gpo.gov/askgpo - Select the category: Federal Depository Libraries 


