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Concept taught in webinar GPO tools DDM2 tools 

Knowing what you are 
profiled for so you can 
review your selection profile 

Review ISP 

 List of Classes – CSV file 

 Item Selection Profile – Item Lister 

 MS Access query 

 Demo how to do counts, create pie 
charts, and color code list 

Review ISP 

 Show List of Classes  

 Depository Selection & Directory > export options 

Maintaining your Online 
Collection 

Review newer online resources that 
have been cataloged 

 NET 

Review newer online resources that have been cataloged 

 URL Locator 
o Selection profile filter 

Building a Foundation 
Collection 

 Review older online resources that have been cataloged 

 item/URL database 
o Results without any ISP filter on it 
o Demo with ISP pulled down from Item Lister  

Bonus Features of DDM2 

Understanding what you are 
receiving 

 Create customized shipping lists 

 Demo Shipping Lists 
o Add an ISP filter to get customized shipping lists 

 Compare with ISP and note how what a library is profiled for is not what they 
are receiving 

 Create a ‘master list of receipts’ and also used as a weeding list 

Understanding your historic 
tangible collection 

 Review what you received back to 1997 

 Demo Shelflist 
o Export options 
o Add ISP filter 

Understanding your historic 
tangible collection 

 Another way to review what you received back to 1997 

 Demo Shelflist database in Tools section 
o Add ISP to a MS Access query 

Understanding how to weed 
your historic tangible 
collection 

Superseded List 
 

Reviewing Superseded List 

 Customized Superseded List based on current selection profile  

 Pull customized Superseded List into Shelflist database and run query to list all 
of item numbers on customized shelflist and supersession instructions 

 
Disclaimer: This is not a “GPO process” – what follows are just tips and tricks an Outreach & Support staffer worked on when working in a depository library. It 
has been refined over the years. Everything was done in MS Office 2010 and Windows 7. If you have a different version of Excel or Windows, some of the steps 
may vary. 
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Concept – Knowing what you are profiled for so you can review your selection profile 
Process – Reviewing your ISP using the LOC and your ISP in MS Access - from GPO files 
 
How are you going to clean up your item selection profile (most likely to stop the unwanted tangible material from arriving in shipment boxes)? 
 
We are going to pull together different files to provide a more accurate picture of what your library is selecting on your item selection profile and in what 
formats they are available in. To do that, we’ll need to import two files into MS Access and then run a simple query. 
 
Step 1 - Download your item selection profile from the Item Lister  
 

 

www.fdlp.gov > Collection Tools > Item Lister 
 
In the drop down box, select Selections in Rows and 
Columns 
 
Type in your library number 
 
Click Submit 

 

And click Download CSV 
 
Follow the prompts on your screen to open the CSV 
file up. Most computers will most likely default to 
opening it up in MS Excel.  
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Delete row one (in green) so that cell A1 is Selections and cell A2 is your first item number.  
 
Change the name in your new cell A1 from Selections to Item Numbers 
 
Note that there are apostrophes in item numbers that have no letters in them. This is so the spreadsheet (software used 
to display the CSV file) does not strip out the leading zeros. 
 
Item numbers must match item numbers found in any other file so that they can ‘match’ – which means we have to strip 
the apostrophes out of the item numbers by: 

 Selecting Column A 

 Find & Select 

 Replace 

 Type the ‘ into the top box and replace it with nothing (leave it blank) 
 

 
Click Replace All. 
 
All the apostrophes should disappear from your item numbers, as will the leading zeroes. 
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Now you have to get the leading zeros back into the item numbers, so the item 
numbers in different files match. 
 
With the column still selected, click on  

 Format 

 Format Cells 

 Select Custom from the list  

 Type 0000 

 Click OK 
 
The leading zeros should be back in the item numbers 
 
Save the list of selected item numbers where you will remember it – as an Excel 
or .xlsx file – NOT a .csv file. You have formatted the cells to include the leading 
zeros, to save it as a CSV file would strip out that formatting. 

 
Step 2 - Download the List of Classes in CSV format. 
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Go to www.fdlp.gov > Collection Tools > List of Classes > List of Classes Data Files 
 
Click Download next to the List of Classes file (NOT the List of Classes Online Only Items file) 
 
After downloading, open the file up. 
 
The file will open up as a text file. Reads pretty messy, huh?! 
 
Don’t worry, when imported into MS Access, it will be formatted in a more readable display. 
 
Save the file where you will remember it - as a text or .txt file. 
 

 
TIP - Close both the Item Selection Profile and the List of Classes file spreadsheets. If you import them while they are open, MS Access will strip out the cell 
formatting’s leading zeros. 
 
Step 3 - Import files into MS Access and create a query. 
 
Open up MS Access. 
 
Create a new or blank database, name it, and save it where you will remember it. 
 
Step 3.1 Import your Item Selection Profile. 
 
With your blank database open, click on External Data. Under Import & Link, click on Excel. Browse until you find your item selection profile spreadsheet and 
click Open. 
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Import the source data into a new table > click OK. 
 

 
Step 3.1.2 Now you have to format the spreadsheet that you just imported into MS Access. 
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Check the box for First Row Contains Column 
Headings >  
 
Click Next > Next > Next and keep the name of the 
file 
 
Click Finish > Close  
 
You have imported your item selection profile, but 
kept most everything at the default settings. 

  
Step 3.2 Import the List of Classes. 
 
In the database, under External Data tab, under Import & Link, select Text File. Browse until you find the list of classes file and click Open. Leave the import 
settings at default and click OK. 
 
Step 3.2.1 Now you have to format the List of Classes file that you just imported into MS Access. 
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It should recognize that the file is delimited, then 
click Next 
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It should identify that the columns are separated by 
a column.  
 
Scroll to the right to ensure that all the columns are 
correct.  
 
Do NOT check the box for First Row Contains Field 
Names because the first row does not contain 
headers. We will have to supply that later. 
 
Click Next 
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You have to name the columns.  
 
With the first column selected, type the name of the 
field in the Field Name box. 
 
Scroll over and click on the each column that you 
want to provide a header or column name for.  Type 
the name of the column in the Field Name box. 
 
For blank columns or unwanted columns, instead of 
naming it, just select the column and check the box 
for “Do not import field (Skip).  
 
Click Next > Next > keep the name of the file  
 
Click Finish > Close 
 
 

 
You have two tables imported (plus the default blank table) in your MS Access database. 
 
Step 3.3 Create a query to get detailed information about what is on your item selection profile. 
 
Step 3.3.1 In the database, click on the Create tab > Query Design 
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Select your two tables (hold the Ctrl key down as 
you click on them), List of Classes and the Item 
Selection Profile tables.  
 
Click Add > Close 
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Click on your Item Numbers column (that was your item selection profile list) 
and drag it to the Item Number column in the List of Classes table.  
 
It will draw a line between the two tables.  
 
That is telling MS Access that those fields are related to each other and contain 
the same values. 
 
Double click on Item Numbers, SuDoc, Title, and Formats (or whatever you 
named the columns as).  
 

  
Step 3.3.2 Create you query fields. 
 

 

The fields you double clicked on will appear below. 

 
 
 

Under Results, click Run    
 
 
 
It will run your query, returning all the Item Numbers, SuDocs, Titles, and 
Formats where it matches your item selection profile. 
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Tip – Going Online or Digital Only? 
 
If you want to go all ‘digital only’, you will have to deselect any item number that has anything other than just ‘EL’ in the format field. If it is a multiple format 
item number, for example, ‘P/EL’, you will have to deselect it or risk getting tangible material for it. 
 
In other words, if you want to drop item numbers with tangible formats associated with them, identify item numbers that can be distributed in a tangible format 
(basically anything that isn’t exclusively listed as “EL” can be issued in a tangible format). 
 
From there, deselect unwanted item numbers in DSIMS 

 
The difference between this Item Selection Profile list and that from DDM2 is that: 

 Item numbers with multiple formats and/or titles are only listed once (on one row) 

 Item numbers with unknown formats are blank in the Formats field. 
 
You can export this query into an Excel file to more easily sort, manipulate, and color code it. 
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To export and manipulate… 
 
Click on External Data tab 
 
Under Export, click on Excel.  
 
Browse to where you want it to be saved to 
 
Check the boxes for both  

 Export data with formatting and layout and  

 Open the destination file after the export 
operation is complete  

 
Click OK and Close 
 

 
Tip - Your analysis will benefit if you add format information when there is no known format listed.  
 
To add a format value where it is missing, select the Formats column and click on Sort & Filter > Sort Z to A.  
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It will prompt you to Expand the selection that is sorts 
 
Click Sort 

 
 

All the item numbers with an unknown format are sorted to the 
bottom 
 
Scroll down to the first bland format cell 
 
Type Unk in the first blank format cell 
 
Mouse over the lower right corner of the Unk cell until the cursor 

forms a plus sign +  
 
Double click on the lower right corner. It will auto fill all the 
remaining empty cells with Unk  

 
 
Save your spreadsheet.  
 
This process can be used to review your selection profile.  
 
Other analysis options: 
 
To see your selection profile broken out by format, in the spreadsheet, select the format column > copy the column > click on a new spreadsheet tab at the 
bottom of your spreadsheet > paste.  
 
Select the column > Sort & Filter > Sort A to Z. 
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Select the column again > Data > Subtotal > OK >  
 
At each change in: format 
Use function: Count 
OK 
 

 
 
It just counted the number of CDs, DVDs, E, EL, MF, Paper, Unknowns formats listed… 

In the upper left corner of the table, click the 2 
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Select and copy 
the counts for 
each of the 
formats, leaving 
out the Grand 
Count. 
 

 

Then Paste it into NotePad or 
TextPad to clear out all the formulas 
‘behind the scenes’ 
 

 

 
Select it again, copy it, and paste it into a new spreadsheet tab at the bottom. You have a count of the item numbers you select broken out by format. 
 
Delete the row ‘format Count 1’. You can manually add the CD Diskettes, DVDs and E Counts if you want to see all the tangible electronic together, or you can 
report them out separately. 
 
Select the Count column, Home > Sort & Filter > Sort Largest to Smallest > Expand the selection. 

Select entire chart 
 

 

Click on Insert > Pie > 
2D Pie 

 
  

EL Count

P Count

Unk Count

MF Count

E Count

CD Count

DVD Count

DISKETTES Count
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As you can see below, this library is profiled for close to 60% in online-only formats. 

You can change the 
Chart Layout 
(Design Tab) to 
view the 
percentages. 
 

 
 
Going back to the original selection profile tab, try color coding your selection profile by format.  
 
Select the format column 
Sort & Filter > Sort A to Z > Expand the selection 
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Select the cells for a 
format, and pick a color to 
shade the cells 
 
Repeat the steps for each 
format until the content for 
each format is shaded 
different colors 

 

 
If you are using data from the List of Classes and Item Lister, select the SuDoc column. Sort & Filter > Sort A to Z > Expand the selection. 
 
Tip - If you are using DDM2 data, select the nsudocstem column. nsudocstem is “naturalized SuDocs”, meaning MS Excel will properly sort the SuDocs stem.  
Sort & Filter > Sort A to Z > Expand the selection.  
 
You are seeing your selection profile in SuDoc stem order, color coded by format. 
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For example, the library here selects the 
Agricultural Statistics in 3 formats, EL, P, and CD 
(colorful, eh?) 
 
They can quickly identify if they want to deselect 
one of the formats.  
 

 
 
Also, you can get a quick sense of how a library is developing a particular area. For example, most libraries select congressional materials in paper and online, or 
microfiche and online. So you will see a pattern of color a/color b/color a/color b/color a/color b/color a/color b… 
 
This library here is a selective, and you can tell that 
they have an ‘illegal’ selection because they select 
both the paper and microfiche version of Y 4.P 
93/1-10:  
 
Otherwise, the rest of the Y4’s for this library are 
consistently a blue/tan/blue/tan pattern, 
reflecting that they select congressional material 
in online and microfiche formats.  
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You can also do all of the above analysis using DDM2, with some caveats... 

 
Concept – Knowing what you are profiled for so you can review your selection profile 
Process – Reviewing your ISP - in DDM2 
 
Overview of DDM2  

 Is a service of Wichita State University 

 It provides search functionality and reports for selection profiles, shipping lists, catalog records, and other GPO data files 

 Its data dates back to 1997 

 DDM2 regularly updates their files from GPO files. They always indicate someplace on their page the last date that they uploaded content. You may have 
to wait for them to update their files. 

 
DDM2: http://govdoc.wichita.edu/ddm2/gdocframes.asp 
 
 

http://govdoc.wichita.edu/ddm2/gdocframes.asp
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The List of Classes is available on the home page 
under List of Classes 
 
The file can be exported  into a spreadsheet.  
 
However, for the purpose of analyzing your item 
selection profile, you do not need to create a query 
in MS Access database like above. 
 
To analyze your selection profile in DDM2, click on 
Depository Selection & Directory > Type in your 
library number and click Submit 
 
 
 
 
 

 
 

The library number is a link. Click on your library 
number. 
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You get a form where you can run queries on your 
selection profile.  
 
The form looks like you have to fill out fields, you 
don’t actually have to though.  
 
You can see your entire profile by just clicking on 
Submit.  
 
Or you can evaluate it by format or other criteria.  
 
Tip – You know how to evaluate what you are 
selecting on your selection profile, but what about 
what you aren’t selecting?  
 
From the form, in the Status drop down box, select 
“Unselected for _____” to see a list of what you are 
NOT selecting. 
 

 
 

You can page through the search results 25 at a time, 
or you can export your selection profile by clicking 
on Export to Excel or Export to CSV 

 
 
From the spreadsheet that opens up, you can manipulate the data in the same way as above – with one important caveat – this is an IMPORTANT CONCEPT for 
when working with DDM2 data… 
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DDM2 breaks out each title and each format for a given item number, separately.  
 
Below, you can see that the SuDoc stem A 1.76: and the title Agriculture Handbooks is repeated twice.  

 
 
This item number is a multi-format item number, meaning if you select it, you are profiled for both the P and the EL format.  
 
Below, you can also see that item numbers that have more than one title and SuDoc associated with it will appear on two lines. 

 
 
DDM2 breaks multiple-format and multiple SuDocs/Titles item numbers out onto two lines, counting each line for each difference. In GPO’s Item Lister, it will 
only reflect that you select the item number once. Therefore – there will likely be a difference between the selection count that you see in DDM2 and in Item 
Lister. This will also be important later on. 
 
When you export to Excel or CSV, you may want to delete the columns you don’t need, like the blank column, selected, active, adate, udate, gpostatus, 
agencycode, agencyname, and frequency. 
 
‘nsudocstem’ is a ‘naturalized SuDoc stem’ so you can sort the list in Excel in proper SuDoc order (very handy). 
 
From here – you can do the same analysis on your selection profile as you did using GPO files above. The difference being how DDM2 lists multiple-format and 
multiple-title/SuDocs item numbers. Be careful if you deselect item numbers based off of DDM2 data. Make sure you are double check if an item number you 
are interested in adding or dropping has multiple formats and/or titles/SuDocs associated with it.  

 
Concept – Maintaining Your Digital Collection 
Process – Reviewing digital resources that have been newly cataloged - from GPO files 
 
Digital resources are constantly being identified and cataloged. A good digital collection requires ongoing and regular maintenance. Maintenance involves 
ensuring continued appropriateness of digital resources in your collection as well as a review of your discovery or access points to the digital material. Most 
importantly, it involves you yourself staying up-to-date with new online or digital resources that may be of interest to your users. 
 
Using the Catalog of U.S. Government Publications (CGP), you can identify newly cataloged digital resources. 
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CGP: http://catalog.gpo.gov/F 
 
Click on New Titles 

 
 
From there, you can click on the links run CGP queries of newly cataloged online/electronic/digital resources. The reports are broken out by different time 
frames.  
 

 
 
You can review the search results page and note resources of interest. Note the OCLC number, CGP System Number, or check the boxes next to the resources 
and email the checked records to yourself. More information on how to email and save CGP records can be found in the Help file by clicking on Help at the top of 
the CGP menu bar. 
 

http://catalog.gpo.gov/F
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Alternatively, you can scroll to the bottom of the 
New Titles page and you can view a spreadsheet 
version of New Electronic Titles – one month at a 
time.  
 

 
 
Open the spreadsheet up by clicking on the month you are interested in (the file with the .csv file extension).  
 
Within the spreadsheet, delete unwanted records, and save the desired records. The remaining records on the list will have the OCLC number and CGP system 
number to make it easier to copy catalog.  
 
Tip - This procedure does not take into account a library’s item selection profile. All resources are reviewed, which may mean that resources that wouldn’t 
otherwise have been captured in a selection profile would get reviewed. 
 
There is an average of about 600-700 online or digital resources cataloged each month. Some would prefer to only have to review resources based on their item 
selection profile. To do that, you will have to either pull the monthly .csv New Electronic Titles list into MS Access and run a query against your library’s item 
selection profile, or, you can use DDM2. 

 
Concept – Maintaining Your Digital Collection 
Process – Reviewing digital resources that have been newly cataloged - from DDM2 
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To evaluate or identify online resources that match your current item selection profile: 
 
DDM2 can run a query and identify all the MARC records created by GPO (since 1997) that have an 856 PURL entry, which matches your current item selection 
profile. 

 

DDM2:  
http://govdoc.wichita.edu/ddm2/gdocframes.asp 
 
Click on URL LOCATOR 
 
The URL Locator is a subset of all GPO MARC records 
dating back to 1997 that have MARC 856 fields 
(PURLs/URLs) 
 

http://govdoc.wichita.edu/ddm2/gdocframes.asp
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In the form, if you want to view all of the records 
with PURLs or URLs in them, just click Submit 
 
Tip - It is recommended that you enter a time frame 
to limit the volume of records returned 
 
 
 
To filter the search results to your current item 
selection profile, in the form, type in your FDL 
number in the Depository column and click Submit 
 
When filtering by your current selection profile, you 
may miss relevant online resources, but you will not 
have to review all the records cataloged in your time 
frame. 
 
 
Tip - You can also search for online resources by 
LSCH, agency, SuDocs stem, etc.  
 
Tip - The ‘%’ symbol is the wildcard character in 
DDM2 
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Search results return online resources cataloged by 
GPO and any limits you put into the form, such as 
your selected time frame, or records that match your 
library’s current item selection profile. 
 
You can:  

 View the item number, title, & SuDocs number 

 View the resource itself by clicking on the PURL 
or URL 

 Make note of the OCLC number 

 Download the MARC bibliographic record in .bib 
format 

 
Caution - You will have to further limit your date 
range if you see that it returns 400 results (the 
maximum search results). Remember that GPO 
catalogs an average of 600-700 online resources a 
month. 
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Once you have identified catalog records of interest, you can note the OCLC number down and copy catalog them, or download the MARC records in .bib format 
from within DDM2.  
 
This process is a good way to regularly review and identify new online or digital resources of interest for your collection. 
 
You have noted that the search results cannot be exported into a spreadsheet for review. There is a way to export the search results. 
 
To export the URL Locator search results: 

Run the query above 
On the DDM2 navigation bar at the top, click on TOOLS 
On the Tools page, click on Export Last Query in MS Excel 
 

 
 

Open the spreadsheet 
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This Tools feature exports the search results of your last query.  
 
The difference is that it does not show you the URL or PURL associated with the record. It only reports the number of URL/PURLs in the record. If you do not 
need to click on the URL/PURL when reviewing the resource for relevancy, then this procedure may make it easier for you to streamline the copy cataloging. If 
you prefer to be able to click on the URL/PURLs as you review them, you will need to use the DDM2 URL Locator search. 
 
These procedures are a good way to regularly identify resources for inclusion in your online or digital depository collection. It is more for ongoing maintenance 
or development. It is not particularly suited to reviewing resources that were cataloged in the past or for identifying core resources that haven’t been updated in 
a while. 

 
Concept – Building a Foundation Collection 
Process – Reviewing older online resources that have been cataloged using DDM2 
 
Identify older digital or online resources that were cataloged in the past. 
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Go to the DDM2 homepage 
http://govdoc.wichita.edu/ddm2/gdocframes.asp 
 
Click on Tools  
 
 

http://govdoc.wichita.edu/ddm2/gdocframes.asp
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item/URL database (Url Access 2013) > Open 
 
 

 

From in the WinZip program, select the 
ItemUrl.accdb and click View 
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View in Associated Program (MS Access) > Open 

 
 

From there, click on the table Urldata to view the 
table. This is a list of all catalog records since 1997.  
 
Fields include the PKID, OCLC number, Item 
number, SuDoc Stem or SuDoc number, URL/PURL, 
Title, REVDATE, NSUDOC, and SUDOCSTEM. 
 
NOTE that the REVDATE is the date that GPO last 
touched the catalog record and PKID stands for 
MARC Primary Key. 
 

 

NOTE that many catalog records have multiple 
PURLs and URLs in it. Each PURL/URL is displayed 
on a separate line in MS Access – so at some point 
in your review, you may want to de-duplicate the 
list by OCLC number or PKID.  
 
For example, in the screenshot to the left, there 
are really only two catalog records here, but each 
catalog record has three URLs and PURLs in them. 
Look at the OCLC numbers. 

 
That process will retrieve all GPO MARC records with 856 MARC fields in them. To further reduce the volume of resources for you to review, you can add your 
item selection profile into the database as a file, and run a query to filter the resources by your profile. 
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With the ItemUrl database open, click External Data > under Import & Link 
click Excel 
 
Browse until you find where you saved your item selection profile in MS 
Excel format (see above), select the file, and click Open > OK  
 
You are advised to pull your item selection profile over from GPO’s Item 
Lister (see above) because if you use DDM2’s selection profile data, you’ll 
have duplicate item numbers listed for item numbers that have multiple 
Formats/SuDoc stems/Titles…If you run a query in MS Access with duplicate 
item numbers in your selection profile, it will duplicate the query results 
too.  

 

You have to format the spreadsheet before 
it can import 
 
Check the box for First Row Contains 
Column Headings 
 
 
 
 
 
 
 
 
 
Next > Next > Next 
 
Leave the name of the table as is or type in 
a new one. 
 
Finish > Close 
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You now have two tables in your MS Access 
database 
 
To build a query, click on Create > Query 
Design 

 
 

In the Show Table dialog box, select your 
two tables and click Add > Close 
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Click and drag between the item number 
field in your selection profile table and the 
Item number field in the Urldata table. 
 
This will tell MS Access that the content in 
those two fields are related 

 
 

Double click on all the fields you want to 
see in your query results 
 
The fields will display down below the 
tables 

 
 

Up at the top, click Run 

 
 
You are looking at a filtered list of catalog records that match your current item selection profile. You can export up to 65,000 rows of data into a MS Excel 
spreadsheet if you like. 
 
You can filter the search results by year, SuDocs stem, etc…to more easily review the records. 
 
Tip – remember that if there are duplicate item numbers or duplicate URLs, MS Access will report the results multiple times. You can sort the results by OCLC 
number to more easily identify duplicate instances of a record. 
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This is a good procedure to get bibliographic records for online resources that haven’t been updated in years into your catalog. 
 
This strategy works for evaluating and/or identifying your online resources, but the process can be applied to tangible materials shipped out since 1997 using the 
SHELFLISTS feature in DDM2. 

 
 

BONUS Features of DDM2 
 

Concept - Understanding what you are currently receiving in tangible format through the FDLP 
Process – Create customized shipping lists for box processing and/or create a master receipt list using DDM2 
 
DDM2 has all the shipping lists going back to 1997. You can view all the content distributed on shipping lists, or you can create shipping lists that are customized 
to your current selection profile. Be careful that if you have made any changes to your selection profile, that you are viewing an accurate reflection of your box 
receipts. 
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From the DDM2 home page, click on SHIPPING LISTS 
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Type in your FDL number in the Depository Id box 
and some other limiter, such as a calendar year and 
month 
 
Submit 

 
 

What is returned is a list of shipping lists 
 
Each shipping list has a red number next to it – that 
is the number of publications your library is currently 
profiled for 
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For example, there were more than two publications 
on this shipping list, but this library is currently only 
profiled for two of the publications that were 
distributed on the shipping list 
 
If your current selection profile matches what your 
profile was when the shipping list was distributed, 
you can click the Export to Excel button to get the 
shipping list data in spreadsheet format 
 

 
 
Please note that this procedure is NOT a guarantee that your library received what is listed as it based off of your current selection profile. Always check when 
DDM2 last refreshed its data from GPO sources so you know what selection profile DDM2 is basing everything off of. 
 
You do not have to limit the shipping list data by your selection profile. Simply do not type in your FDL number if you want a list of everything that was shipped 
out on a shipping list. 
 
When limiting the Shipping List feature by your selection profile, be careful to add or remove publications listed or not listed in the results when you make 
changes to your selection profile 
 
Tip - Some libraries regularly go into this feature and copy and paste the customized shipping lists into a master spreadsheet of their depository holdings.  
 
Further, a master list of depository receipts can be used to create future withdrawal lists. Just sort the list by shipdate and identify publications that were 
shipped out over 5 years ago and are thus eligible for withdrawal after regional approval. 
 
Tip - Some libraries regularly use this feature to bypass having to compare the paper shipping lists found in the depository boxes and their selection profile. It 
can streamline the box processing if DDM2 has uploaded the shipping list files you are working on. 

 
Concept - Understanding your historic tangible collection 
Process – Use DDM2’s Shelflist feature to identify resources distributed (back to 1997) that match your current selection 
profile 
 
There is a difference between what you have profiled to receive through the FDLP (your item selection profile) and what you actually receive. The Federal 
government does not issue publications on a schedule like the commercial publishing industry. To understand what you are actually receiving, you have to look 
at the Shelflist feature of DDM2. 
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From DDM2 homepage, click on Shelf Lists. Type in your library number, a fiscal or calendar year, and Submit.  
 

DO NOT RUN THE QUERY for all data. DDM2 data goes back to 1997 and it will “kill” your computer to run a query that large!!! 
 
This Shelf List query isn’t entirely accurate. DDM2 has loaded all the shipping lists going back to 1997. It knows your CURRENT item selection profile. 
When you run a Shelf List query, it is taking all the shipping lists that it has, and it is filtering to your CURRENT selection profile. If you have changed any 
of your item selections during the time period you are looking at, it will not be reflected in the end result. So you could be missing publications on your 
list that you received, but have deselected since – or - you could have publications on your list that you didn’t receive because you didn’t select the item 
numbers ‘back then’ but you do now.  
 
You can run the query for different time periods to compile a list of what you likely received. As your selection profile has likely varied over the years, 
results will vary. 
 
The list will not acknowledge any supersession or other forms of withdrawal that your library has done to your collection. 

 
To make it easier to manage, export the data into a spreadsheet.  
 
Export to Excel or Export to CSV. 
 
You have a list of what you should have received during you specified time period, according to your current selection profile. It includes the item number, 
SuDoc stem, title, shipping list number (abbreviated), and the shipdate listed on the shipping list. 
 
Select and highlight the item number column > Sort & Filter > Sort A to Z > Expand the selection. 
 
Copy the item number column and paste it into a new spreadsheet tab. 
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With the column still highlighted, click on Data > 
Subtotal > At each change in: item, Use function 
Count > OK. 
 

 
 

Again, click on the 2 in the upper left corner of the 
table so you only view the mid-level outline. 

 
 
Select and copy the item number and count columns. Don’t select the Grand Count information. 
 
Paste it into TextPad or NotePad to clear out the formatting.  
Select All, Copy, Paste into a new spreadsheet tab. 
 
Select and highlight the column with the actual count data in it. Home > Sort & Filter > Sort Largest to Smallest > Expand the selection > Sort. 
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Select both columns > Insert > 
Pie > 2D Pie 

 
 
You can see above that over 50% of this library’s ACTUAL receipts come from only 4 item numbers. 
 
Tip - If you have to reduce your incoming tangible footprint in a short amount of time, focus on the item numbers that are heavily distributed, don’t worry about 
the item numbers that are not heavily distributed. You can’t see it here, but for this library, only 122 item numbers were distributed in fiscal year 2013. Yet they 
are a regional and they select 100% of everything! That means that most of the item selection profile didn’t get distributed FY 2013. 
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Caution: Watch what you deselect!!! If you drop an item number that has multiple formats associated with it, you lose both titles/SuDocs/format associated 
with that item number.  

 
 
So for example, if you deselect item numbers 0011 or 0003, you will lose both P and EL formats on your selection profile! 

 
Concept - Understanding your historic tangible collection 
Process – Use DDM2’s Shelflist feature to identify resources distributed back to 1997 that match your current selection 
profile 
 
There is an easier way to export shelflist data going back to 1997, using the Shelflist Database. This process works best if your library’s selection profile has not 
changed much over the years. 
 

On the DDM2 home page, click on Tools > Download 
shelflist Database Shelflist Access 2013 

 
 
Open the Access database like above. 
 
With the Shelflist database open, you can see a list of everything shipped out since 1997.  
 
To filter the shelflist to your likely receipts over the years, import your selection profile into the database (see above). 
 
Create a query between the two tables where the item number fields are related to each other. Run the query. Export the results if it is under 65,000 rows. 

 
Concept – Understanding how to weed your historic tangible collection 
Process – Use DDM2 to create a customized Superseded List based off of your current selection profile 
 
Note – the Superseded List is a reference source for supersession criteria and it provides examples of specific publications that are superseded or have special 
considerations. The list itself has not been updated by the FDLP community since 2009, but is still largely accurate as tangible resources sitting on shelves still 
qualify or otherwise meet the supersession criteria. 
 
The Superseded List can be downloaded on FDLP.gov in the Weeding A Depository Collection article at http://www.fdlp.gov/requirements-guidance-
2/guidance/30-weeding-a-depository-collection. However, this list is not in a spreadsheet format.  

http://www.fdlp.gov/requirements-guidance-2/guidance/30-weeding-a-depository-collection
http://www.fdlp.gov/requirements-guidance-2/guidance/30-weeding-a-depository-collection


47 

 

 

On the DDM2 home page, click on 
SUPERSEDED LIST 
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You can filter the 
Superseded List by your 
current selection profile by 
adding your FDL number to 
the Depository id Filter box. 
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The Superseded List based off of a 
library’s current selection profile 

 
 
Note that the search results cannot be exported directly in this feature. 
 
But you can click on Tools > Export Last Query into Microsoft Excel > Open 
 
Printing either the whole Superseded List out or just the Superseded List for your current selection profile may make it easier to identify areas out in your stacks 
that can be weeded. 
 
Tip - You could use the Shelflist database (see above), import the spreadsheet version of the entire Superseded List, import your selection profile, and create a 
query (where the item number is linked together in all three tables), so you can identify resources your library likely received (back to 1997), and include 
supersession instructions in the output file.  
 
Reminders: 

 You have to make sure the item numbers are formatted correctly in each file.  

 Publications may be listed more than once if they are listed more than once in the Shelflist or in the Superseded List. 
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 This list will only return publications where there are instructions for the item number in the Superseded List – so there are receipts that are older than 
five years that you likely received but are not on this list, because it does not have anything listed under the item number. 

 Note that item numbers have changed over the years, so there may be resources that you received in print, but the item number has changed to 
something new and your selection profile was automatically updated. 

 
Note below how some publications are listed more than once (annoying), but, it is easy to figure out that the earlier edition should be superseded (nice!). 

 
 
Using this process, it is fairly easy to identify large runs of serials that are eligible for weeding. And while this procedure is very clunky and open to errors, it is a 
way to help identify or target those smaller pockets of publications that can be weeded, like pamphlets.  
  
 
 
 
 
 


